Bild "misc:gb.png" Sorry, this content hasn't been translated to English yet. I work on it :) Bild "misc:gb.png"

moziloCMS 1.12.php8

Schon seit geraumer Zeit gibt es die aktuelle Version 2.0 von moziloCMS, die natürlich auch unter der aktuellen PHP-Version 8 läuft. Für eine Neuinstallation von moziloCMS ist Version 2.0 die erste Wahl.

Manchmal gibt es aber gute Gründe, auch die alte Version 1.12 weiter zu betreiben. Zum Beispiel, wenn eine bestehende Website nicht ohne Weiteres auf moziloCMS 2.0 aktualisiert werden kann, weil noch nicht alle eingesetzten Plugins für die neue Version verfügbar sind. (Auch viele der von mir geschriebenen moziloCMS-Plugins laufen bisher nur unter moziloCMS 1.12.)
Da inzwischen die meisten Hoster auf PHP 8 umstellen, ist es natürlich sehr hinderlich, dass moziloCMS 1.12 dann nicht mehr funktioniert.

Deswegen habe ich auf GitHub einen Fork von moziloCMS 1.12 erstellt und diesen für PHP 8 fitgemacht. Ich setze diese Version 1.12.php8 selbst ein, kann aber natürlich nicht für absolute Fehlerfreiheit garantieren.
Sollten Fehler auftreten (oder eben auch nicht), bitte ich um Feedback im mozilo-Supportforum.

Download: moziloCMS 1.12.php8 (Komplettpaket)

https://github.com/azett/mozilo1/archive/refs/tags/1.12.php8.zip

Update von 1.12 auf 1.12.php8

Das Update einer vorhandenen Instanz von moziloCMS 1.12 auf Version 1.12.php8 ist schnell erledigt:

Das wars schon. Hat alles funktioniert, meldet die Startseite von moziloAdmin als installierte moziloCMS-Version: 1.12.php8 ("Amalia").
Sollten auf der Website nach dem Update noch Fehler angezeigt werden, müssen möglicherweise noch Drittanbieter-Plugins PHP-8-fähig gemacht werden. Fragen Sie deren Entwickler, ob aktualisierte Versionen vorliegen.

Download: moziloCMS 1.12.php8 (Update-Paket)

https://github.com/azett/mozilo1/files/8054465/112to112php8.zip